Webmin parser not woking

Hello, I’m using Webmin 2.111 and I installed the Webmin Collection to block brute force attacks. I simulated some attacks, but I see that the parser can’t parse any line from the webmin.log file.

andreasbrett/webmin-logs : Hits : 54 / parsed : - / Unparsed : 54
child-andreasbrett/webmin-logs : Hits : 108/ parsed : - / Unparsed : 108

Thank you in advance!

Could you provide the full output of cscli metrics?

Capture d’écran 2024-07-02 123739

Thank you for your support. all parsers are working correctly except webmin.

can you post an example log line from the logs? you can redact any PII information such as IP and usernames.

Hello, here is a log when I did some testing. thank you

Best if you paste the log lines so I can use them locally to update the parsers / test. Like I said you redact the IP and Username.

Sent you via MSG. thank you

To mark the thread as solved here is the details:

  • The parser was working as intended on provided logs line
  • The issue was there was no configured log sources so I am confused how they shown up in metrics, but the user solved the issue by providing an acquisition with the correct label

As always if anyone has any issues please reply and reopen thread.

1 Like