Fresh Firewall bouncer install issue

Just trying a fresh install of crowdsec on Ubuntu 18.04 x64 and hit this issue installing the firewall bouncer. It’s looking for 0.0.13 dependency which obviously not there.

The following packages have unmet dependencies:
crowdsec-firewall-bouncer : Depends: crowdsec-firewall-bouncer-nftables (= 0.0.13) but 0.0.15 is to be installed or
crowdsec-firewall-bouncer-iptables (= 0.0.13) but 0.0.15 is to be installed
E: Unable to correct problems, you have held broken packages.

The packages were updated yesterday i can see to 0.0.15, was there something missed or am I missing something?


Hello @Mike !

You should only install crowdsec-firewall-bouncer-iptables (or crowdsec-firewall-bouncer-nftables).

The crowdsec-firewall-bouncer is something that is being removed (and is going to be deleted from repositories) : previous version required both crowdsec-firewall-bouncer and crowdsec-firewall-bouncer-{iptables,nftables} and it was confusing people.

Please let me know if it’s good :smiley:

That worked. I followed an old install procedure. Thanks.

1 Like