Debian 12 crowdsec-firewall-bouncer-iptables

After this command i got error.
apt install crowdsec-firewall-bouncer-iptables

root@observer ~ # apt install crowdsec-firewall-bouncer-iptables
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,693 kB of archives.
After this operation, 12.7 MB of additional disk space will be used.
Selecting previously unselected package crowdsec-firewall-bouncer-iptables.
(Reading database … 38401 files and directories currently installed.)
Preparing to unpack …/crowdsec-firewall-bouncer-iptables_0.0.28_amd64.deb …
Unpacking crowdsec-firewall-bouncer-iptables (0.0.28) …
Setting up crowdsec-firewall-bouncer-iptables (0.0.28) …
cscli/crowdsec is present, generating API key
API Key successfully created
Created symlink /etc/systemd/system/ → /etc/systemd/system/crowdsec-firewall-bouncer.service.
Job for crowdsec-firewall-bouncer.service failed because the control process exited with error code.
See “systemctl status crowdsec-firewall-bouncer.service” and “journalctl -xeu crowdsec-firewall-bouncer.service” for details.
dpkg: error processing package crowdsec-firewall-bouncer-iptables (–configure):
installed crowdsec-firewall-bouncer-iptables package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@observer ~ # systemctl status crowdsec-firewall-bouncer.service

● crowdsec-firewall-bouncer.service - The firewall bouncer for CrowdSec
Loaded: loaded (/etc/systemd/system/crowdsec-firewall-bouncer.service; enabled; preset: enabled)
Active: activating (start-pre) since Wed 2024-03-20 18:26:38 CET; 1s ago
Cntrl PID: 139109 (crowdsec-firewa)
Tasks: 6 (limit: 154413)
Memory: 6.9M
CPU: 19ms
CGroup: /system.slice/crowdsec-firewall-bouncer.service
└─139109 /usr/bin/crowdsec-firewall-bouncer -c /etc/crowdsec/bouncers/crowdsec-firewall-bouncer.yaml -t

Mar 20 18:26:38 observer systemd[1]: Starting crowdsec-firewall-bouncer.service - The firewall bouncer for CrowdSec…

journalctl -xeu crowdsec-firewall-bouncer.service


User self resolved via discord thread

Here TLDR; CrowdSec had a port conflict and was not running. Upon changing the port and then reflecting that within the bouncer configuration it worked fine.

1 Like

Thanks. I solved this.