Bouncer config fail: address already in use

Hi all. I’m fairly new to the Linux world, but I’m working to learn quickly. I have a headless Ubuntu 20.04.3 box running several home office services, including a web server. I’m guessing that my issue is relatively simple, but I’m having trouble finding information on how to sort it out.

I’m trying to configure CrowdSec to run on this box, but when I install the bouncer crowdsec-firewall-bouncer-iptables it installs ok, but looking at the dashboard it shows me that there is not a bouncer running, and when I run crowdsec -info it shows me the error
time="28-09-2021 10:15:25" level=fatal msg="listen tcp bind: address already in use"

I’m assuming that this error comes from one of my other services already using port 8080 on localhost. Following information in other posts here, I’ve tried changing the CrowdSec port used in both:
but I get the same error no matter what port I choose.

Does anyone have any suggestions on what step(s) I’m missing?

Hello @Beautor,

Crowdsec is launched with systemd and its log file is in /var/log/crowdsec.log. I suppose that it say
listen tcp bind: address already in use because you already have the crowdsec service running (which listen on

If you really have another service running on, just run sudo systemctl restart crowdsec when you have changed your configuration file and check the log in /var/log/crowdsec.log.

Note: There is no -info in crowdsec flag, so running crowdsec -info will just try to run a new crowdsec service.