Email alert don't working

Hello, i have a problem with configuration on /etc/crowdsec/notifications/email.yaml. file
I don’t know if the problem is on the informations i put there.

i created gmail account for my smtp server to use it to send me mails alerts. and i use those credentials as smtp username, smtp password and email sender


Can you share the crowdsec.log file when it tries to send notifications ? It will make it easier to help :slight_smile:

here is the logs… I don’t know where is the problem. Maybe in my configuration’s file

A few questions :

  • I don’t see email plugin errors : Can you share your config (plugin config and profile.yaml) to be sure it’s enabled ?
  • You have a timeout when reaching CAPI : isn’t your machine filtered when reaching internet ?

here is the email configuration’s file, i explained on the screenshot what informations i put.

here is the profile configuration’s file, i enabled email.


I see in your profile that you do have a profile before the one with notifications that has on_success set to break : Format | CrowdSec

So if your alert matches the previous profile, this one won’t be evaluated :slight_smile:

hi, i already changed this and no update. unfortunately It didn’t work.

Did you reload your service after your chance ?
Also can you share the full profiles.yaml file with some of crowdsec.log when a decision gets triggered ?

In your previous logs, the notification didn’t even get triggered so it sounds like it might be a profiles.yaml issue

i see one error up there.

The error says that the login / password isn’t valid (it’s gmail rejecting it)

okay i got it but do you have any proposal for me?

check your login and password, there might be a typo :slight_smile: but the error is outside of crowdsec’s scope it seems