Caddy-bouncer on caddy docker trying to connect to external LAPI host

I have the api setup. I am trying to connect to the docker external host LAPI on port :8080. I’ve tried using the docker bridge ip 172.17. 0.1 but I am getting connection refused. I know the host is listening to port 127.0.0.1:8080
I’ve also added the docker ip to the list of trusted_ips in the config file, but still can’t connect to the API server, connection refused.
Any ideas? Is it a possibilty?
Thanks
Gord

If the CrowdSec is listening on the loopback interface (127.0.0.1) then the docker bridge doesnt know about crowdsec listening on that port since its a different interface.

You can change the configuration of crowdsec to listen on 0.0.0.0:8080 which means all interfaces so it will be accessible to the docker network. However, be careful using 0.0.0.0 as if your system does not have a firewall it will expose CrowdSec to the internet (Which is not too bad however, you should always follow the principle of minimizing your exposed surface)

Yes, I thought of that too. What I decided to do is take crowdsec out of bridge mode and into host mode. That works. This is a proxmox build. I was interested in trying to filter all the VM’s through caddy and crowdsec.
One other thing “http.auto_https” enabled crowdsec complains about “localhost” and enables certs for it.
Can that be disabled?
Thanks.
G.