# Unable to retrieve latest crowdsec version

**URL:** <https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625>\
**Category:** crowdsec\
**Created:** [January 30, 2024, 7:15pm UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625 "2024-01-30T19:15:46Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![kitzune](https://avatars.discourse-cdn.com/v4/letter/k/e480ec/32.png) [@kitzune](https://discourse.crowdsec.net/u/kitzune)\
**Post date:** [January 30, 2024, 7:15pm UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/1 "2024-01-30T19:15:46Z")

</div>

Hi,

I am new to crowdsec and walked through a tutorial about setting it up with traefik and a bouncer. All things worked fine but the other containers won’t start as it depends on an healthcheck from crowdsec which failed. Looking into the log output I get the following:

```auto
time="2024-01-30T20:04:57+01:00" level=warning msg="Unable to retrieve latest crowdsec version: Get \"https://version.crowdsec.net/latest\": dial tcp: lookup version.crowdsec.net on 127.0.0.11:53: read udp 127.0.0.1:45661->127.0.0.11:53: i/o timeout, using hub branch 'master'"

```

and

```auto
time="2024-01-30T20:05:07+01:00" level=fatal msg="failed to update hub: failed http request for hub index: Get \"https://hub-cdn.crowdsec.net/master/.index.json\": dial tcp: lookup hub-cdn.crowdsec.net on 127.0.0.11:53: read udp 127.0.0.1:41818->127.0.0.11:53: i/o timeout"

```

BTW the container is running some time and after attaching to it with:

```auto
docker exec -it crowdsec bash

```

i get kicked out of the container session and after running `docker ps` I can see the container isn’t running anymore.

Any idea what this can be about?

Thanks in advance

---

<div class="post-metadata">

**Author:** ![smu44](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@smu44](https://discourse.crowdsec.net/u/smu44)\
**Post date:** [February 1, 2024, 9:29am UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/2 "2024-02-01T09:29:49Z")

</div>

Hi,

From your error outputs I can see a DNS failure (timeout).  
So, something’s may be wrong with your Docker network.

---

<div class="post-metadata">

**Author:** ![iiAmLoz](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/iiamloz/32/386_2.png) [@iiAmLoz](https://discourse.crowdsec.net/u/iiAmLoz)\
**Post date:** [February 1, 2024, 9:34am UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/3 "2024-02-01T09:34:59Z")

</div>

Sorry I was going to reply sooner, @smu44 is right the docker DNS is timing out. If you use a custom DNS solution for your network might be best to not bind to all listeners.

---

<div class="post-metadata">

**Author:** ![kitzune](https://avatars.discourse-cdn.com/v4/letter/k/e480ec/32.png) [@kitzune](https://discourse.crowdsec.net/u/kitzune)\
**Post date:** [February 1, 2024, 9:59am UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/4 "2024-02-01T09:59:23Z")

</div>

No problem.

Yeah I thought of that as well and don‘t know where things got wrong. In had to prune the docker ecosystem because it didn‘t copy my host resolv.conf. Always got 127.0.011 in the resolv.conf of the crowdsec container. Not even adding the dns server in the compose file added it.

After that and running compose again, it worked.

Do you maybe know what caused the wrong resolv.conf? I found nothing about it on the web.

---

<div class="post-metadata">

**Author:** ![snoopeppers](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@snoopeppers](https://discourse.crowdsec.net/u/snoopeppers)\
**Post date:** [May 13, 2024, 2:27pm UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/5 "2024-05-13T14:27:10Z")

</div>

I’ve been using crowdsec for almost 2 years now and this happens to me sporadically. I can’t determine the actual root cause - but my system will be working fine for months and then break with this error. I forget the exact steps I took last time, but restarting the Docker service and resolv.conf were both involved. I have the issue again and will document better.

What I’ve never been able to figure out is why this **demands exiting the container** when it should be functional regardless of whether or not it can learn of version of updates. This behavior makes troubleshooting extremely difficult. Not to mention, as a dependency for my reverse proxy, takes all my other services down with it.

---

<div class="post-metadata">

**Author:** ![BJReplay](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/bjreplay/32/884_2.png) [@BJReplay](https://discourse.crowdsec.net/u/BJReplay)\
**Post date:** [May 28, 2024, 8:08am UTC](https://discourse.crowdsec.net/t/unable-to-retrieve-latest-crowdsec-version/1625/6 "2024-05-28T08:08:07Z")

</div>

This came up as a search result for me; I’ve been using CrowdSec for a year or so, but two of my servers dropped off the air after an update of some docker components.

Restarting CrowdSec or the entire docker stack didn’t work.

I had to restart the server.

Server was still working, but without CrowdSec working, and so all CrowdSec protected websites weren’t available; luckily they were only the control planes for services that were still up and running.
