# CloudFlare Bouncer - not\_entitled.max\_rules

**URL:** <https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502>\
**Category:** crowdsec\
**Created:** [December 31, 2021, 11:50pm UTC](https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502 "2021-12-31T23:50:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Trenta](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/trenta/32/244_2.png) [@Trenta](https://discourse.crowdsec.net/u/Trenta)\
**Post date:** [December 31, 2021, 11:50pm UTC](https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502/1 "2021-12-31T23:50:34Z")

</div>

Hello,

I was hoping that to find someone who has dealt with this before. I have five domains under Cloudflare. I use a free account with them. When setting up the bouncer, I created the token as needed but I get the issue as seen in the screenshot. Anyone dealt with this before?

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/crowdsec/original/1X/118e7de3453ed45d407793d35771909ec82c9a39.png)

---

<div class="post-metadata">

**Author:** ![sbs2001](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/sbs2001/32/197_2.png) [@sbs2001](https://discourse.crowdsec.net/u/sbs2001)\
**Post date:** [January 3, 2022, 2:00pm UTC](https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502/2 "2022-01-03T14:00:21Z")

</div>

@Trenta Do you have existing firewall rules for the domains already ? For free account CF allows you to have atmost 5 rules. The bouncer creates one rule and this might be exceeding the quota. Thus causing the error.

Other than that, do the tokens have access as given here [https://raw.githubusercontent.com/crowdsecurity/cs-cloudflare-bouncer/main/docs/assets/token\_permissions.png](https://raw.githubusercontent.com/crowdsecurity/cs-cloudflare-bouncer/main/docs/assets/token_permissions.png) ?

---

<div class="post-metadata">

**Author:** ![sbs2001](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/sbs2001/32/197_2.png) [@sbs2001](https://discourse.crowdsec.net/u/sbs2001)\
**Post date:** [January 7, 2022, 6:31am UTC](https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502/3 "2022-01-07T06:31:18Z")

</div>

@Trenta I was able to reproduce this error by doing the following:

1. Have existing 5 firewall rules on a zone. Free plan.
2. Run the bouncer. The bouncer produces the above error when it tries to create for crowdsec stuff.

This is caused due exceeding firewall rule limit. To fix this you’ll need to delete an existing rule.

---

<div class="post-metadata">

**Author:** ![Trenta](https://dub1.discourse-cdn.com/flex013/user_avatar/discourse.crowdsec.net/trenta/32/244_2.png) [@Trenta](https://discourse.crowdsec.net/u/Trenta)\
**Post date:** [January 7, 2022, 2:19pm UTC](https://discourse.crowdsec.net/t/cloudflare-bouncer-not-entitled-max-rules/502/4 "2022-01-07T14:19:58Z")

</div>

It turns out that it was failing due to my other domains I have under Cloudflare. The main one I was focusing on had no rules in place, but the other domains had five rules on in most of them. Removed them, ran the setup again, and boom. Thank you so much. Just a brain fart on my end. 🙂
